[Solved] Unimus unable to discover/login ssh devices

Unimus support forum
Post Reply
ekoons5159
Posts: 3
Joined: Wed Aug 28, 2019 6:35 pm

Wed Aug 28, 2019 6:39 pm

I'm having an issue where Unimus is unable to discover login to devices with ssh or telnet. Some devices work, some do not. If I take the username/password combination that I have setup for Unimus and login with an ssh client on my laptop it works fine, so it's not the device and it's not the username/password combo. This also works with RANCID, which I'm evaluating Unimus as a replacement. Here are the log entries:

2019-08-28 14:27:22.561 DEBUG 16703 --- [discovery-18] n.u.c.s.d.CliDiscoveryServiceImpl : Discovering available SSH port on '10.0.8.41'
2019-08-28 14:27:22.562 TRACE 16703 --- [discovery-18] n.u.core.service.cli.ssh.SshConnector : Checking ssh availability on 10.0.8.41:22 within timeout 10000s
2019-08-28 14:27:22.615 TRACE 16703 --- [discovery-18] n.u.core.service.cli.ssh.SshConnector : Closing expect session
2019-08-28 14:27:22.615 TRACE 16703 --- [discovery-18] n.u.core.service.cli.ssh.SshConnector : Closing TCP socket connection
2019-08-28 14:27:22.615 TRACE 16703 --- [discovery-18] n.u.core.service.cli.ssh.SshConnector : Ssh available on '10.0.8.41'
2019-08-28 14:27:22.615 TRACE 16703 --- [discovery-18] n.u.c.s.d.CliDiscoveryServiceImpl : SSH on '10.0.8.41' discovered on port 'PortDto(id=0, portNumber=22)'
2019-08-28 14:27:22.615 DEBUG 16703 --- [discovery-18] n.u.c.s.d.CliDiscoveryServiceImpl : Discovering usable credentials on '10.0.8.41'
2019-08-28 14:27:22.615 TRACE 16703 --- [discovery-18] n.u.c.s.d.CliDiscoveryServiceImpl : Testing 1 credentials through SSH on '10.0.8.41'
2019-08-28 14:27:22.865 TRACE 16703 --- [discovery-18] n.u.c.s.d.CliDiscoveryServiceImpl : Trying credentials 'Credential{id=10, username='ubackup', password = 12 character(s)}' on '10.0.8.41'
2019-08-28 14:27:22.866 TRACE 16703 --- [discovery-18] n.u.core.service.cli.ssh.SshConnector : Creating SSH session to 10.0.8.41:22 with 'Credential{id=10, username='ubackup', password = 12 character(s)}', connectTimeout 10000
2019-08-28 14:27:22.871 DEBUG 16703 --- [discovery-18] n.u.core.service.cli.ssh.SshConnector : Failed to connect SSH to 10.0.8.41:22 reason JSchException - Session.connect: java.net.SocketException: Connection reset
2019-08-28 14:27:22.871 DEBUG 16703 --- [discovery-18] n.u.c.s.d.CliDiscoveryServiceImpl : Error during credential discovery on '10.0.8.41' using 'SSH'. Error: 'JSchException', details: 'Session.connect: java.net.SocketException: Connection reset'
2019-08-28 14:27:22.871 DEBUG 16703 --- [discovery-18] n.u.c.s.d.CliDiscoveryServiceImpl : Could not login to SSH on '10.0.8.41' with any of available credentials
ekoons5159
Posts: 3
Joined: Wed Aug 28, 2019 6:35 pm

Wed Aug 28, 2019 6:40 pm

Was running Unimus 1.10.0, just updated to 1.10.4 and same issue.
User avatar
Tomas
Posts: 756
Joined: Sat Jun 25, 2016 12:33 pm

Wed Aug 28, 2019 6:44 pm

Hello,

We commonly see "SocketException: Connection reset" on some Cisco devices and some slower / older devices.

This can be fixed by adjusting the "inter-connection-delay" setting.
We have a Wiki article that will show you how:
https://wiki.unimus.net/display/UNPUB/C ... t+timeouts

Setting the "inter-connection-delay" to about 1000 (1 second) should fix this.
ekoons5159
Posts: 3
Joined: Wed Aug 28, 2019 6:35 pm

Wed Aug 28, 2019 7:19 pm

That worked. Thank you!!!
Post Reply