[Solved] strange problem with 1.10.3

Unimus support forum
Post Reply
avious2
Posts: 22
Joined: Thu May 18, 2017 10:10 pm

Tue Jul 30, 2019 6:41 pm

I have a strange problem that I cannot figure out after updating to 1.10.3.

After the update, I have 5 devices that now always show backup failed when they worked before.

I've tried deleting these devices and re-adding them and still, the backup fails.

I have other devices in the same subnets that backup fine.

From the Unimus server, I can both ping and ssh into the devices fine.

They are 1 rocket M5 and 4 rocket M2 radios.

I have other rocket M5 and M2 radios that backup fine, running that same firmware as the failing ones.

In the logfile I get the following:
2019-07-30 12:57:55.778 WARN 4216 --- [backup-2] n.u.c.d.v.u.UbntUniversalBackupDriver : Output recognition timeout reached while trying to talk to IP ADDRESS HERE!
2019-07-30 12:57:55.778 WARN 4216 --- [backup-2] n.u.c.d.v.u.UbntUniversalBackupDriver : Unable to download backup from 'IP ADDRESS HERE' - 'Expect operation fails (timeout: 95000 ms) for matcher: anyOf(regexp('(?i)(?:wrong|invalid|incomplete|incorrect|bad|ambiguous|unrecognized|unsupported|unknown|no matching) (?:command|input|usage|action|entry)|(?:not enough|invalid|bad) (?:parameters?|arguments?)|command (?:unknown|failed)|command.+(?:not found|not recognized|not supported|not available)|parsing error|command parser? error|(?:failed|not possible).+(?:check|try) again|expected end of command|sh: .+: not found|(?m)^(?-m)failure:.+|\^ ?(?:keyword|command|input) mis[- ]?match|syntax error.+|invalid syntax'),regexp('(?i)(?:permission|access) (?:denied|refused|forbidden)|(?:don't|doesn't|do not|does not) have (?:permission|access|authorization)|(?:bad|invalid|incorrect) (?:secrets?|password)|authorization (?:failed|failure|denied|refused)'),regexp('(?i).+: .+: (?:no such file|not found)'),TailingRegexp('(?i)(?m)^(?-m)\d?(?:X[MWCS]|WA|TI|AF.*?|SW|US|BZ)\d?(?:\.v\d+?\.\d+?(?:\.\d+?){0,2}(?:-[Uu]\d+?|-RC.*?|-beta.*?|-cpu.*?)?)?# $', 250))'!

But like I said from the command line on the Unimus server I can both ping said IP address and SSH into it from the command line.

So I'm not sure what to check next.

The one thing I have not tried is rebooting the actual radios to see if that changes anything, but I really don't think that would make a difference.

The Unimus server is a windows 10 64bit fully updated xeon server.
User avatar
Tomas
Posts: 752
Joined: Sat Jun 25, 2016 12:33 pm

Tue Jul 30, 2019 8:55 pm

Hi,

We have made some changes to the airOS drivers in 1.10.3 because of added support for the newer 2CX, 2WA, etc. models.
It's possible these changes for some reason broke backup for you.

Can you please enable device output logging in Unimus?
(Other settings > Debug mode > Enable device output logging)

After this is enabled, run a backup on one of the failing devices.
After the backup fails, please download the device output log file.

After that, please create a ticked on our Portal, and attach the log file there.

Thanks!
avious2
Posts: 22
Joined: Thu May 18, 2017 10:10 pm

Tue Jul 30, 2019 10:16 pm

Thank you for your reply and I would follow instructions but to my surprise, I restarted each radio that was failing the backups and now they each back up fine.

So I guess it was firmware bugs or something, I don't know what would cause that.

But anyway, thank you for responding.
Post Reply