[Fixed in 1.10.0] SSL cert pusing to UBNT edgeswitches

Unimus support forum
Post Reply
SeanCTS
Posts: 60
Joined: Thu Nov 02, 2017 7:29 pm
Location: Orlando, FL

Thu Feb 21, 2019 6:03 pm

Hi Unimus team,

I love the product and still rocking it since late 2017.

However, we're looking to automate ssl cert copies to our UBNT edgeswitches via ssh, however looks like it takes a 10 seconds for the switch to copy and then respond.

Is there a method of telling to wait for the device to respond before inputting next commands?
User avatar
Tomas
Posts: 727
Joined: Sat Jun 25, 2016 12:33 pm

Fri Feb 22, 2019 1:51 pm

Hi,

Unimus automatically waits for device prompt after issuing commands, and only when device actually responds with the prompt it issues another command.

Is the push job failing for you?
If so, could you please create a ticket on the Portal and attach the device output log file?
(Other settings > Debug mode > Device output logging)

Thanks!
SeanCTS
Posts: 60
Joined: Thu Nov 02, 2017 7:29 pm
Location: Orlando, FL

Fri Feb 22, 2019 4:11 pm

Yep, it fails. Interaction Error.

Here's the debug logs

Edit... the forum reply attachment feature is bugged. "Temporary Folder could not be found or is not writable"

Is there an email I can send these logs to?
User avatar
Tomas
Posts: 727
Joined: Sat Jun 25, 2016 12:33 pm

Fri Feb 22, 2019 4:32 pm

Apologies for the forum issue, we will fix that ASAP.

Please create a ticket on our Portal, and attach the debug file there.

Thanks!
SeanCTS
Posts: 60
Joined: Thu Nov 02, 2017 7:29 pm
Location: Orlando, FL

Fri Feb 22, 2019 4:55 pm

Ticket Submitted. Thanks!
SeanCTS
Posts: 60
Joined: Thu Nov 02, 2017 7:29 pm
Location: Orlando, FL

Tue Feb 26, 2019 2:04 pm

Hey Tomas,

Submitted ticket last week - 4924-522-548-83 , no response. Mind taking a look at the logs?
User avatar
Tomas
Posts: 727
Joined: Sat Jun 25, 2016 12:33 pm

Tue Feb 26, 2019 2:07 pm

Apologies, we are a little overloaded right now - we are rushing to finish development on 1.10.0 to publish a public beta this week.
(we want a lot of testing on this release - as it will be the last release branch before 2.0.0)

We will get to the ticket asap.
SeanCTS
Posts: 60
Joined: Thu Nov 02, 2017 7:29 pm
Location: Orlando, FL

Fri Mar 15, 2019 2:23 pm

Hi Tomas, it's been a while. Has any progress been made?
Tomas wrote:
Tue Feb 26, 2019 2:07 pm
Apologies, we are a little overloaded right now - we are rushing to finish development on 1.10.0 to publish a public beta this week.
(we want a lot of testing on this release - as it will be the last release branch before 2.0.0)

We will get to the ticket asap.
User avatar
Tomas
Posts: 727
Joined: Sat Jun 25, 2016 12:33 pm

Thu Mar 28, 2019 4:38 pm

Big thanks to SeanCTS for his patience and help while we debugged and fixed this.

Happy to report that this has been fixed, and the fix will be a part of the 1.10.0 release.

The fix required 2 parts:
1) issue on our end that prevented Unimus from answering the "y/n" promp the switch presented
2) the default timeouts needed to be adjusted, as the switch took longer to finish this operation than the default timeouts:
https://wiki.unimus.net/display/UNPUB/C ... t+timeouts
Post Reply