[Fixed in 1.7.0] Failed to create device preset

Beta release announcements and discussion around them
Post Reply
User avatar
ukzerosniper
Posts: 28
Joined: Sat Jul 30, 2016 6:46 pm
Location: England
Contact:

Thu May 03, 2018 4:29 pm

Hi Guys,

I am trying to do a mass config test. I have created the config shown in the code below. I called it "Rebuild all packages".

I assigned it to a test router, copied and pasted the commands into the command box as shown below. I tested the commands in a copy paste on the router and all went well.

When I hit save, I get the error "Failed to create device preset".

Code: Select all

/queue tree remove [/queue tree find]
/queue type remove [/queue type find where default=no]
/ppp profile remove [/ppp profile find name!="default"]
/ip firewall mangle remove [/ip firewall mangle find]
/ip firewall address-list  remove [/ip firewall address-list find list ~"^[0-9]+\\..*"]

:delay 1

/queue type
add kind=pcq name="1Mbps / 0.25Mbps Default Connection Download" \
    pcq-classifier=dst-address pcq-limit=200KiB pcq-rate=1M pcq-total-limit=\
    80000KiB
add kind=pcq name="1Mbps / 0.25Mbps Default Connection Upload" \
    pcq-classifier=src-address pcq-limit=40KiB pcq-rate=250k pcq-total-limit=\
    16000KiB
add kind=pcq name="80Mbps Home Download" pcq-classifier=dst-address pcq-limit=200KiB pcq-rate=85M pcq-total-limit=80000KiB
add kind=pcq name="80Mbps Home Upload" pcq-classifier=src-address pcq-limit=40KiB pcq-rate=45M pcq-total-limit=16000KiB
add kind=pcq name="50Mbps Home Download" pcq-burst-rate=65M \
    pcq-burst-threshold=55M pcq-burst-time=15s pcq-classifier=dst-address \
    pcq-limit=200KiB pcq-rate=55M pcq-total-limit=80000KiB
add kind=pcq name="50Mbps Home Upload" pcq-burst-rate=12M \
    pcq-burst-threshold=7M pcq-burst-time=15s pcq-classifier=src-address \
    pcq-limit=40KiB pcq-rate=7M pcq-total-limit=16000KiB
add kind=pcq name="30Mbps Home Download" pcq-burst-rate=40M \
    pcq-burst-threshold=33M pcq-burst-time=15s pcq-classifier=dst-address \
    pcq-limit=200KiB pcq-rate=33M pcq-total-limit=80000KiB
add kind=pcq name="30Mbps Home Upload" pcq-burst-rate=10M \
    pcq-burst-threshold=5M pcq-burst-time=15s pcq-classifier=src-address \
    pcq-limit=40KiB pcq-rate=5M pcq-total-limit=16000KiB	
add kind=pcq name="10Mbps Home Download" pcq-classifier=dst-address \
    pcq-limit=200KiB pcq-rate=11M pcq-total-limit=80000KiB
add kind=pcq name="10Mbps Home Upload" pcq-classifier=src-address pcq-limit=\
    40KiB pcq-rate=2M pcq-total-limit=16000KiB
add kind=pcq name="8Mbps/3Mbps Split Download" pcq-classifier=dst-address \
    pcq-limit=200KiB pcq-rate=9M pcq-total-limit=80000KiB
add kind=pcq name="8Mbps/3Mbps Split Upload" pcq-classifier=src-address \
    pcq-limit=40KiB pcq-rate=4M pcq-total-limit=16000KiB
add kind=pcq name="7.5Mbps Home Download" pcq-classifier=dst-address \
    pcq-limit=200KiB pcq-rate=8M pcq-total-limit=80000KiB
add kind=pcq name="7.5Mbps Home Upload" pcq-classifier=src-address pcq-limit=\
    40KiB pcq-rate=1M pcq-total-limit=16000KiB
add kind=pcq name="5Mbps Home Download" pcq-classifier=dst-address pcq-limit=\
    200KiB pcq-rate=6M pcq-total-limit=80000KiB
add kind=pcq name="5Mbps Home Upload" pcq-classifier=src-address pcq-limit=\
    40KiB pcq-rate=660k pcq-total-limit=16000KiB
add kind=pcq name="2.5Mbps Home Download" pcq-classifier=dst-address \
    pcq-limit=200KiB pcq-rate=3M pcq-total-limit=80000KiB
add kind=pcq name="2.5Mbps Home Upload" pcq-classifier=src-address pcq-limit=\
    40KiB pcq-rate=660k pcq-total-limit=16000KiB
add kind=pcq name="80Mbps Business Download" pcq-classifier=dst-address pcq-limit=200KiB pcq-rate=85M pcq-total-limit=80000KiB
add kind=pcq name="80Mbps Business Upload" pcq-classifier=src-address pcq-limit=40KiB pcq-rate=45M pcq-total-limit=16000KiB
add kind=pcq name="50Mbps Business Download" pcq-classifier=dst-address pcq-limit=200KiB pcq-rate=55M pcq-total-limit=80000KiB
add kind=pcq name="50Mbps Business Upload" pcq-classifier=src-address pcq-limit=40KiB pcq-rate=7M pcq-total-limit=16000KiB
add kind=pcq name="30Mbps Business Download" pcq-classifier=dst-address pcq-limit=200KiB pcq-rate=33M pcq-total-limit=80000KiB
add kind=pcq name="30Mbps Business Upload" pcq-classifier=src-address pcq-limit=40KiB pcq-rate=5M pcq-total-limit=16000KiB	
add kind=pcq name="15Mbps Business Download" pcq-classifier=dst-address pcq-limit=200KiB pcq-rate=17M pcq-total-limit=80000KiB
add kind=pcq name="15Mbps Business Upload" pcq-classifier=src-address pcq-limit=40KiB pcq-rate=7M pcq-total-limit=16000KiB	
add kind=pcq name="10Mbps Business Download" pcq-classifier=dst-address \
    pcq-limit=200KiB pcq-rate=11M pcq-total-limit=80000KiB
add kind=pcq name="10Mbps Business Upload" pcq-classifier=src-address \
    pcq-limit=40KiB pcq-rate=2M pcq-total-limit=16000KiB
add kind=pcq name="7.5Mbps Business Download" pcq-classifier=dst-address \
    pcq-limit=200KiB pcq-rate=8M pcq-total-limit=80000KiB
add kind=pcq name="7.5Mbps Business Upload" pcq-classifier=src-address \
    pcq-limit=40KiB pcq-rate=1M pcq-total-limit=16000KiB
add kind=pcq name="5Mbps Business Download" pcq-classifier=dst-address \
    pcq-limit=200KiB pcq-rate=6M pcq-total-limit=80000KiB
add kind=pcq name="5Mbps Business Upload" pcq-classifier=src-address \
    pcq-limit=40KiB pcq-rate=660k pcq-total-limit=16000KiB
add kind=pcq name="2.5Mbps Business Download" pcq-classifier=dst-address \
    pcq-limit=200KiB pcq-rate=3M pcq-total-limit=80000KiB
add kind=pcq name="2.5Mbps Business Upload" pcq-classifier=src-address \
    pcq-limit=40KiB pcq-rate=660k pcq-total-limit=16000KiB
add kind=pcq name="20Mbps / 20Mbps  Business Symm Download" pcq-classifier=\
    dst-address pcq-limit=200KiB pcq-rate=21M pcq-total-limit=80000KiB
add kind=pcq name="20Mbps / 20Mbps Business Symm Upload" pcq-classifier=\
    src-address pcq-limit=40KiB pcq-rate=21M pcq-total-limit=16000KiB
add kind=pcq name="15Mbps / 15Mbps Business Symm Download" pcq-classifier=\
    dst-address pcq-limit=200KiB pcq-rate=16M pcq-total-limit=80000KiB
add kind=pcq name="15Mbps / 15Mbps Business Symm Upload" pcq-classifier=\
    src-address pcq-limit=40KiB pcq-rate=16M pcq-total-limit=16000KiB
add kind=pcq name="10Mbps / 10Mbps Business Symm Download" pcq-classifier=\
    dst-address pcq-limit=200KiB pcq-rate=11M pcq-total-limit=80000KiB
add kind=pcq name="10Mbps / 10Mbps Business Symm Upload" pcq-classifier=\
    src-address pcq-limit=40KiB pcq-rate=11M pcq-total-limit=16000KiB
add kind=pcq name="7.5Mbps / 7.5Mbps Business Symm Download" pcq-classifier=\
    dst-address pcq-limit=200KiB pcq-rate=8M pcq-total-limit=80000KiB
add kind=pcq name="7.5Mbps / 7.5Mbps  Business Symm Upload" pcq-classifier=\
    src-address pcq-limit=40KiB pcq-rate=8M pcq-total-limit=16000KiB
add kind=pcq name="5Mbps / 5Mbps Business Symm Download" pcq-classifier=\
    dst-address pcq-limit=200KiB pcq-rate=6M pcq-total-limit=80000KiB
add kind=pcq name="5Mbps / 5Mbps  Business Symm Upload" pcq-classifier=\
    src-address pcq-limit=40KiB pcq-rate=6M pcq-total-limit=16000KiB
add kind=pcq name="2.5Mbps / 2.5Mbps  Business Symm Download" pcq-classifier=\
    dst-address pcq-limit=200KiB pcq-rate=3M pcq-total-limit=80000KiB
add kind=pcq name="2.5Mbps / 2.5Mbps Business Symm Upload" pcq-classifier=\
    src-address pcq-limit=40KiB pcq-rate=3M pcq-total-limit=16000KiB
add kind=pcq name="15Mbps/5Mbps Bridge Holder Download" pcq-classifier=\
    dst-address pcq-limit=200KiB pcq-rate=16M pcq-total-limit=80000KiB
add kind=pcq name="15Mbps/5Mbps Bridge Holder Upload" pcq-classifier=\
    src-address pcq-limit=40KiB pcq-rate=6M pcq-total-limit=16000KiB
add kind=pcq name="50Mbps/50Mbps Business Download JHCS Office" \
    pcq-classifier=dst-address pcq-limit=200KiB pcq-rate=50M pcq-total-limit=\
    80000KiB
add kind=pcq name="50Mbps/50Mbps Business Upload JHCS Office" pcq-classifier=\
    src-address pcq-limit=40KiB pcq-rate=50M pcq-total-limit=16000KiB
	

		
	
	
	
	
	
	
	

/queue tree
add name=VOIP-UPLOAD packet-mark=VOIP_UPLOAD parent=global priority=1 queue=\
    pcq-upload-default
add name=VOIP_DOWNLOAD packet-mark=VOIP_DOWNLOAD parent=global priority=1 \
    queue=pcq-upload-default
add max-limit=200M name="Main Download" parent=global queue=\
    pcq-download-default
add max-limit=100M name="Home Download" parent="Main Download" priority=3 \
    queue=pcq-download-default
add max-limit=100M name="Business Download" parent="Main Download" priority=1 \
    queue=default
add max-limit=50M name="Business Symmetrical Download" parent="Main Download" \
    priority=2 queue=default
add max-limit=100M name="Main Upload" parent=global queue=pcq-upload-default
add max-limit=60M name="Business Upload" parent="Main Upload" queue=default
add max-limit=50M name="Business Symmetrical Upload" parent="Main Upload" \
    queue=default
add max-limit=60M name="Home Upload" parent="Main Upload" queue=\
    pcq-upload-default
add name="Default Connection Download" packet-mark=\
    "000. EU_Default_Connection_1Mbps/0.25Mbps_Download" parent=\
    "Home Download" priority=1 queue=\
    "1Mbps / 0.25Mbps Default Connection Download"
add name="Default Connection Upload" packet-mark=\
    "000. EU_Default_Connection_1Mbps/0.25Mbps_Upload" parent="Home Upload" \
    priority=1 queue="1Mbps / 0.25Mbps Default Connection Upload"
add name="80Mbps / 40Mbps Home Download" packet-mark="57. EU_Home_80Mbps/40Mbps_Download" parent="Home Download" priority=1 queue="80Mbps Home Download"
add name="80Mbps/40Mbps Home Upload" packet-mark="57. EU_Home_80Mbps/40Mbps_Upload" parent="Home Upload" priority=1 queue="80Mbps Home Upload"
add name="50Mbps / 5Mbps Home Download" packet-mark=\
    "56. EU_Home_50Mbps/5Mbps_Download" parent="Home Download" priority=1 \
    queue="50Mbps Home Download"
add name="50Mbps/5Mbps Home Upload" packet-mark=\
    "56. EU_Home_50Mbps/5Mbps_Upload" parent="Home Upload" priority=1 queue=\
    "50Mbps Home Upload"
add name="30Mbps / 3Mbps Home Download" packet-mark=\
    "55. EU_Home_30Mbps/3Mbps_Download" parent="Home Download" priority=1 \
    queue="30Mbps Home Download"
add name="30Mbps/3Mbps Home Upload" packet-mark=\
    "55. EU_Home_30Mbps/3Mbps_Upload" parent="Home Upload" priority=1 queue=\
    "30Mbps Home Upload"
add name="10Mbps / 1Mbps Home Download" packet-mark=\
    "53. EU_Home_10Mbps/1Mbps_Download" parent="Home Download" priority=1 \
    queue="10Mbps Home Download"
add name="10Mbps / 1Mbps Home Upload" packet-mark=\
    "53. EU_Home_10Mbps/1Mbps_Upload" parent="Home Upload" priority=1 queue=\
    "10Mbps Home Upload"
add name="8Mbps / 3Mbps Split Download" packet-mark=\
    "54. EU_Home_8Mbps/3Mbps-Download" parent="Home Download" priority=1 \
    queue="8Mbps/3Mbps Split Download"
add name="8Mbps/3Mbps Split Upload" packet-mark=\
    "54. EU_Home_8Mbps/3Mbps-Upload" parent="Home Upload" priority=1 queue=\
    "8Mbps/3Mbps Split Upload"
add name="7.5Mbps / 750Kbps Home Download" packet-mark=\
    "52. EU_Home_7.5Mbps/750Kbps_Download" parent="Home Download" priority=1 \
    queue="7.5Mbps Home Download"
add name="7.5Mbps / 750Kbps Home Upload" packet-mark=\
    "52. EU_Home_7.5Mbps/750Kbps_Upload" parent="Home Upload" priority=1 \
    queue="7.5Mbps Home Upload"
add name="5Mbps / 512Kbps Home Download" packet-mark=\
    "51. EU_Home_5Mbps/512Kbps_Download" parent="Home Download" priority=1 \
    queue="5Mbps Home Download"
add name="5Mbps / 512Kbps Home Upload" packet-mark=\
    "51. EU_Home_5Mbps/512Kbps_Upload" parent="Home Upload" priority=1 queue=\
    "5Mbps Home Upload"
add name="2.5Mbps / 0.5Kbps Home Download" packet-mark=\
    "50. EU_Home_2.5Mbps/0.5Kbps_Download" parent="Home Download" priority=1 \
    queue="2.5Mbps Home Download"
add name="2.5Mbps / 0.5Kbps Home Upload" packet-mark=\
    "50. EU_Home_2.5Mbps/0.5Kbps_Upload" parent="Home Upload" priority=1 \
    queue="2.5Mbps Home Upload"
add name="80Mbps / 40Mbps Business Download" packet-mark="27. EU_Business_80Mbps/40Mbps-Download" parent="Business Download" priority=1 queue="80Mbps Business Download"
add name="80Mbps / 40Mbps Business Upload" packet-mark="27. EU_Business_80Mbps/40Mbps-Upload" parent="Business Upload" priority=1 queue="80Mbps Business Upload"
add name="50Mbps / 5Mbps Business Download" packet-mark="26. EU_Business_50Mbps/5Mbps-Download" parent="Business Download" priority=1 queue="50Mbps Business Download"
add name="50Mbps / 5Mbps Business Upload" packet-mark="26. EU_Business_50Mbps/5Mbps-Upload" parent="Business Upload" priority=1 queue="50Mbps Business Upload"
add name="30Mbps / 3Mbps Business Download" packet-mark="25. EU_Business_30Mbps/3Mbps-Download" parent="Business Download" priority=1 queue="30Mbps Business Download"
add name="30Mbps / 3Mbps Business Upload" packet-mark="25. EU_Business_30Mbps/3Mbps-Upload" parent="Business Upload" priority=1 queue="30Mbps Business Upload"	
add name="15Mbps / 5Mbps Business Download" packet-mark="24. EU_Business_15Mbps/5Mbps-Download" parent="Business Download" priority=1 queue="15Mbps Business Download"
add name="15Mbps / 5Mbps Business Upload" packet-mark="24. EU_Business_15Mbps/5Mbps-Upload" parent="Business Upload" priority=1 queue="15Mbps Business Upload"	
add name="10Mbps / 1Mbps Business Download" packet-mark=\
    "23. EU_Business_10Mbps/1Mbps-Download" parent="Business Download" \
    priority=1 queue="10Mbps Business Download"
add name="10Mbps / 1Mbps Business Upload" packet-mark=\
    "23. EU_Business_10Mbps/1Mbps-Upload" parent="Business Upload" priority=1 \
    queue="10Mbps Business Upload"
add name="7.5Mbps / 750Kbps Business Download" packet-mark=\
    "22. EU_Business_7.5Mbps/750Kbps-Download" parent="Business Download" \
    priority=1 queue="7.5Mbps Business Download"
add name="7.5Mbps / 750Kbps Business Upload" packet-mark=\
    "22. EU_Business_7.5Mbps/750Kbps-Upload" parent="Business Upload" \
    priority=1 queue="7.5Mbps Business Upload"
add name="5Mbps / 512Kbps Business Download" packet-mark=\
    "21. EU_Business_5.0Mbps/512Kbps-Download" parent="Business Download" \
    priority=1 queue="5Mbps Business Download"
add name="5Mbps / 512Kbps Business Upload" packet-mark=\
    "21. EU_Business_5.0Mbps/512Kbps-Upload" parent="Business Upload" \
    priority=1 queue="5Mbps Business Upload"
add name="2.5Mbps / 0.5Kbps Business Download" packet-mark=\
    "20. EU_Business_2.5Mbps/0.5Kbps-Download" parent="Business Download" \
    priority=1 queue="2.5Mbps Business Download"
add name="2.5Mbps / 0.5Kbps Business Upload" packet-mark=\
    "20. EU_Business_2.5Mbps/0.5Kbps-Upload" parent="Business Upload" \
    priority=1 queue="2.5Mbps Business Upload"
add name="20Mbps / 20Mbps Business Symmetrical Download" packet-mark=\
    "6. EU_Business_Symm_20Mbps/20Mbps-Download" parent=\
    "Business Symmetrical Download" priority=1 queue=\
    "20Mbps / 20Mbps  Business Symm Download"
add name="20Mbps / 20Mbps Business Symmetrical Upload" packet-mark=\
    "6. EU_Business_Symm_20Mbps/20Mbps-Upload" parent=\
    "Business Symmetrical Upload" priority=1 queue=\
    "20Mbps / 20Mbps Business Symm Upload"
add name="15Mbps / 15Mbps Business Symmetrical Download" packet-mark=\
    "5. EU_Business_Symm_15Mbps/15Mbps-Download" parent=\
    "Business Symmetrical Download" priority=1 queue=\
    "15Mbps / 15Mbps Business Symm Download"
add name="15Mbps / 15Mbps Business Symmetrical Upload" packet-mark=\
    "5. EU_Business_Symm_15Mbps/15Mbps-Upload" parent=\
    "Business Symmetrical Upload" priority=1 queue=\
    "15Mbps / 15Mbps Business Symm Upload"
add name="10Mbps / 10Mbps  Business Symmetrical Download" packet-mark=\
    "4. EU_Business_Symm_10Mbps/10Mbps-Download" parent=\
    "Business Symmetrical Download" priority=1 queue=\
    "10Mbps / 10Mbps Business Symm Download"
add name="10Mbps / 10Mbps Business Symmetrical Upload" packet-mark=\
    "4. EU_Business_Symm_10Mbps/10Mbps-Upload" parent=\
    "Business Symmetrical Upload" priority=1 queue=\
    "10Mbps / 10Mbps Business Symm Upload"
add name="7.5Mbps / 7.5Mbps Business Symmetrical Download" packet-mark=\
    "3. EU_Business_Symm_7.5Mbps/7.5Mbps-Download" parent=\
    "Business Symmetrical Download" priority=1 queue=\
    "7.5Mbps / 7.5Mbps Business Symm Download"
add name="7.5Mbps / 7.5Mbps Business Symmetrical Upload" packet-mark=\
    "3. EU_Business_Symm_7.5Mbps/7.5Mbps-Upload" parent=\
    "Business Symmetrical Upload" priority=1 queue=\
    "7.5Mbps / 7.5Mbps  Business Symm Upload"
add name="5Mbps / 5Mbps Business Symmetrical Download" packet-mark=\
    "2. EU_Business_Symm_5Mbps/5Mbps-Download" parent=\
    "Business Symmetrical Download" priority=1 queue=\
    "5Mbps / 5Mbps Business Symm Download"
add name="5Mbps / 5Mbps Business Symmetrical Upload" packet-mark=\
    "2. EU_Business_Symm_5Mbps/5Mbps-Upload" parent=\
    "Business Symmetrical Upload" priority=1 queue=\
    "5Mbps / 5Mbps  Business Symm Upload"
add name="2.5Mbps / 2.5Mbps Business Symmetrical Download" packet-mark=\
    "1. EU_Business_Symm_2.5Mbps/2.5Mbps-Download" parent=\
    "Business Symmetrical Download" priority=1 queue=\
    "2.5Mbps / 2.5Mbps  Business Symm Download"
add name="2.5Mbps / 2.5Mbps Business Symmetrical Upload" packet-mark=\
    "1. EU_Business_Symm_2.5Mbps/2.5Mbps-Upload" parent=\
    "Business Symmetrical Upload" priority=1 queue=\
    "2.5Mbps / 2.5Mbps Business Symm Upload"
add name="15Mbps / 5Mbps Bridge Holder Download" packet-mark=\
    "100. EU_BridgeHolder_15Mbps/5Mbps_Traffic-Download" parent=\
    "Home Download" priority=1 queue="15Mbps/5Mbps Bridge Holder Download"
add name="15Mbps / 5Mbps Bridge Holder Upload" packet-mark=\
    "100. EU_BridgeHolder_15Mbps/5Mbps_Traffic-Upload" parent="Home Upload" \
    priority=1 queue="15Mbps/5Mbps Bridge Holder Upload"
add name="50Mbps / 50Mbps Business Download JHCS Office" packet-mark=\
    OFFICE_JHCS_Traffic_Download parent="Business Download" priority=1 queue=\
    "50Mbps/50Mbps Business Download JHCS Office"
add name="50Mbps/50Mbps Business Upload JHCS Office" packet-mark=\
    OFFICE_JHCS_Traffic_Upload parent="Business Upload" priority=1 queue=\
    "50Mbps/50Mbps Business Upload JHCS Office"
	
	
	
	
	
	
	
	
	
/ppp profile
add address-list="000. EU_Default_Connection_1Mbps/0.25Mbps" change-tcp-mss=\
    yes local-address=10.20.0.1 name="Default Service 1Mbps / 0.25Mbps" \
    only-one=yes
add address-list="57. EU_Home_80Mbps/40Mbps" change-tcp-mss=yes local-address=10.20.0.1 name="Home User 80Mbps / 40Mbps" only-one=yes
add address-list="56. EU_Home_50Mbps/5Mbps" change-tcp-mss=yes local-address=\
    10.20.0.1 name="Home User 50Mbps / 5Mbps" only-one=yes
add address-list="55. EU_Home_30Mbps/3Mbps" change-tcp-mss=yes local-address=\
    10.20.0.1 name="Home User 30Mbps / 3Mbps" only-one=yes
add address-list="53. EU_Home_10Mbps/1Mbps" change-tcp-mss=yes local-address=\
    10.20.0.1 name="Home User 10Mbps / 1Mbps" only-one=yes
add address-list="54. EU_Home_8Mbps/3Mbps" change-tcp-mss=yes local-address=\
    10.20.0.1 name="Home User 8Mbps / 3Mbps" only-one=yes
add address-list="52. EU_Home_7.5Mbps/750Kbps" change-tcp-mss=yes \
    local-address=10.20.0.1 name="Home User 7.5Mbps / 0.75Mbps" only-one=yes
add address-list="51. EU_Home_5Mbps/512Kbps" change-tcp-mss=yes \
    local-address=10.20.0.1 name="Home User 5Mbps / 0.5Mbps" only-one=yes
add address-list="50. EU_Home_2.5Mbps/0.5Kbps" change-tcp-mss=yes \
    local-address=10.20.0.1 name="Home User 2.5Mbps / 0.5Mbps" only-one=yes
add address-list="27. EU_Business_80Mbps/40Mbps" change-tcp-mss=yes local-address=10.20.0.1 name="Business User 80Mbps / 40Mbps" only-one=yes
add address-list="26. EU_Business_50Mbps/5Mbps" change-tcp-mss=yes local-address=10.20.0.1 name="Business User 50Mbps / 5Mbps" only-one=yes	
add address-list="25. EU_Business_30Mbps/3Mbps" change-tcp-mss=yes local-address=10.20.0.1 name="Business User 30Mbps / 3Mbps" only-one=yes	
add address-list="24. EU_Business_15Mbps/5Mbps" change-tcp-mss=yes local-address=10.20.0.1 name="Business User 15Mbps / 5Mbps" only-one=yes
add address-list="23. EU_Business_10Mbps/1Mbps" change-tcp-mss=yes \
    local-address=10.20.0.1 name="Business User 10Mbps / 1Mbps " only-one=yes
add address-list="22. EU_Business_7.5Mbps/750Kbps" change-tcp-mss=yes \
    local-address=10.20.0.1 name="Business User 7.5Mbps / 0.75Mbps" only-one=\
    yes
add address-list="21. EU_Business_5.0Mbps/512Kbps" change-tcp-mss=yes \
    local-address=10.20.0.1 name="Business User 5Mbps / 0.5Mbps" only-one=yes
add address-list="20. EU_Business_2.5Mbps/0.5Kbps" change-tcp-mss=yes \
    local-address=10.20.0.1 name="Business User 2.5Mbps / 0.5Mbps" only-one=\
    yes
add address-list="6. EU_Business_Symm_20Mbps/20Mbps" change-tcp-mss=yes \
    local-address=10.20.0.1 name="Business Symm 20Mbps / 20Mbps" only-one=yes
add address-list="5. EU_Business_Symm_15Mbps/15Mbps" change-tcp-mss=yes \
    local-address=10.20.0.1 name="Business Symm 15Mbps / 15Mbps" only-one=yes
add address-list="4. EU_Business_Symm_10Mbps/10Mbps" change-tcp-mss=yes \
    local-address=10.20.0.1 name="Business Symm 10Mbps / 10Mbps" only-one=yes
add address-list="3. EU_Business_Symm_7.5Mbps/7.5Mbps" change-tcp-mss=yes \
    local-address=10.20.0.1 name="Business Symm 7.5Mbps / 7.5Mbps" only-one=\
    yes
add address-list="2. EU_Business_Symm_5Mbps/5Mbps" change-tcp-mss=yes \
    local-address=10.20.0.1 name="Business Symm 5Mbps / 5Mbps" only-one=yes
add address-list="1. EU_Business_Symm_2.5Mbps/2.5Mbps" change-tcp-mss=yes \
    local-address=10.20.0.1 name="Business Symm 2.5Mbps / 2.5Mbps" only-one=\
    yes
add address-list="100. EU_BridgeHolder_15Mbps/5Mbps" change-tcp-mss=yes \
    local-address=10.20.0.1 name="BridgeHolder Private 15Mbps / 5Mbps" \
    only-one=yes
add address-list=OFFICE_JHCS change-tcp-mss=yes local-address=10.20.0.1 name=\
    "JHCS OFFICE Profile 50/50" only-one=yes
	
	
	
	
	
	
	
	
	
/ip firewall mangle
add action=mark-connection chain=forward comment=\
    "Mark connection VOIP SIP - DSCP (TOS) 26" dscp=26 new-connection-mark=\
    VOIP passthrough=yes protocol=udp
add action=mark-connection chain=forward comment=\
    "Mark connection VOIP RTP - DSCP (TOS) 46" dscp=46 new-connection-mark=\
    VOIP passthrough=yes protocol=udp
add action=mark-packet chain=forward comment=\
    "Mark VOIP - CONNECTION-TYPE SIP" connection-type=sip new-packet-mark=\
    VOIP_DOWNLOAD passthrough=no protocol=udp src-address-list=WAN_RANGE
add action=mark-packet chain=forward comment=\
    "Mark VOIP - CONNECTION-TYPE SIP" connection-type=sip dst-address-list=\
    WAN_RANGE new-packet-mark=VOIP_UPLOAD passthrough=no protocol=udp
add action=mark-packet chain=prerouting comment="Mark packet VOIP UPLOAD" \
    connection-mark=VOIP new-packet-mark=VOIP_UPLOAD passthrough=no \
    src-address-list=WAN_RANGE
add action=mark-packet chain=prerouting comment="Mark packet VOIP DOWNLOAD" \
    connection-mark=VOIP dst-address-list=WAN_RANGE new-packet-mark=\
    VOIP_DOWNLOAD passthrough=no
add action=mark-connection chain=prerouting comment="Mark Connections For Queu\
    e Trees - 000. EU_Default_Connection_1Mbps/0.25Mbps" new-connection-mark=\
    "000. EU_Default_Connection_1Mbps/0.25Mbps" src-address-list=\
    "000. EU_Default_Connection_1Mbps/0.25Mbps"
add action=mark-connection chain=postrouting comment="Mark Connections For Que\
    ue Trees - 000. EU_Default_Connection_1Mbps/0.25Mbps" \
    new-connection-mark="000. EU_Default_Connection_1Mbps/0.25Mbps" \
    src-address-list="000. EU_Default_Connection_1Mbps/0.25Mbps"
add action=mark-packet chain=prerouting comment="Mark Packets For Upload - 000\
    . EU_Default_Connection_1Mbps/0.25Mbps_Upload" connection-mark=\
    "000. EU_Default_Connection_1Mbps/0.25Mbps" new-packet-mark=\
    "000. EU_Default_Connection_1Mbps/0.25Mbps_Upload" passthrough=no \
    src-address-list="000. EU_Default_Connection_1Mbps/0.25Mbps"
add action=mark-packet chain=prerouting comment="Mark Packets For Downloading \
    - 000. EU_Default_Connection_1Mbps/0.25Mbps_Download" connection-mark=\
    "000. EU_Default_Connection_1Mbps/0.25Mbps" dst-address-list=39 \
    new-packet-mark="000. EU_Default_Connection_1Mbps/0.25Mbps_Download" \
    passthrough=no
add action=mark-packet chain=postrouting comment="Mark Packets For Downloading\
    \_- NAT 000. EU_Default_Connection_1Mbps/0.25Mbps_Download" \
    connection-mark="000. EU_Default_Connection_1Mbps/0.25Mbps" \
    dst-address-list="000. EU_Default_Connection_1Mbps/0.25Mbps" \
    new-packet-mark="000. EU_Default_Connection_1Mbps/0.25Mbps_Download" \
    passthrough=no
add action=mark-connection chain=prerouting comment="Mark Connections For Queue Trees - 57. EU_Home_80Mbps/40Mbps" new-connection-mark="57. EU_Home_80Mbps/40Mbps_Connection" src-address-list="57. EU_Home_80Mbps/40Mbps"
add action=mark-connection chain=postrouting comment="Mark Connections For Queue Trees - 57. EU_Home_80Mbps/40Mbps" new-connection-mark="57. EU_Home_80Mbps/40Mbps_Connection" src-address-list="57. EU_Home_80Mbps/40Mbps"
add action=mark-packet chain=prerouting comment="Mark Packets For Upload - 57. EU_Home_80Mbps/40Mbps_Upload" connection-mark="57. EU_Home_80Mbps/40Mbps_Connection" new-packet-mark="57. EU_Home_80Mbps/40Mbps_Upload" passthrough=no src-address-list="57. EU_Home_80Mbps/40Mbps"
add action=mark-packet chain=prerouting comment="Mark Packets For Downloading - 57. EU_Home_80Mbps/40Mbps_Download" connection-mark="57. EU_Home_80Mbps/40Mbps_Connection" dst-address-list="57. EU_Home_80Mbps/40Mbps" new-packet-mark="57. EU_Home_80Mbps/40Mbps_Download" passthrough=no
add action=mark-packet chain=postrouting comment="Mark Packets For Downloading - NAT 57. EU_Home_80Mbps/40Mbps_Download" connection-mark="57. EU_Home_80Mbps/40Mbps_Connection" dst-address-list="57. EU_Home_80Mbps/40Mbps" new-packet-mark="57. EU_Home_80Mbps/40Mbps_Download" passthrough=no
add action=mark-connection chain=prerouting comment=\
    "Mark Connections For Queue Trees - 56. EU_Home_50Mbps/5Mbps" \
    new-connection-mark="56. EU_Home_50Mbps/5Mbps_Connection" \
    src-address-list="56. EU_Home_50Mbps/5Mbps"
add action=mark-connection chain=postrouting comment=\
    "Mark Connections For Queue Trees - 56. EU_Home_50Mbps/5Mbps" \
    new-connection-mark="56. EU_Home_50Mbps/5Mbps_Connection" \
    src-address-list="56. EU_Home_50Mbps/5Mbps"
add action=mark-packet chain=prerouting comment=\
    "Mark Packets For Upload - 56. EU_Home_50Mbps/5Mbps_Upload" \
    connection-mark="56. EU_Home_50Mbps/5Mbps_Connection" new-packet-mark=\
    "56. EU_Home_50Mbps/5Mbps_Upload" passthrough=no src-address-list=\
    "56. EU_Home_50Mbps/5Mbps"
add action=mark-packet chain=prerouting comment=\
    "Mark Packets For Downloading - 56. EU_Home_50Mbps/5Mbps_Download" \
    connection-mark="56. EU_Home_50Mbps/5Mbps_Connection" dst-address-list=\
    "56. EU_Home_50Mbps/5Mbps" new-packet-mark=\
    "56. EU_Home_50Mbps/5Mbps_Download" passthrough=no
add action=mark-packet chain=postrouting comment=\
    "Mark Packets For Downloading - NAT 56. EU_Home_50Mbps/5Mbps_Download" \
    connection-mark="56. EU_Home_50Mbps/5Mbps_Connection" dst-address-list=\
    "56. EU_Home_50Mbps/5Mbps" new-packet-mark=\
    "56. EU_Home_50Mbps/5Mbps_Download" passthrough=no
add action=mark-connection chain=prerouting comment=\
    "Mark Connections For Queue Trees - 55. EU_Home_30Mbps/3Mbps" \
    new-connection-mark="55. EU_Home_30Mbps/3Mbps_Connection" \
    src-address-list="55. EU_Home_30Mbps/3Mbps"
add action=mark-connection chain=postrouting comment=\
    "Mark Connections For Queue Trees - 55. EU_Home_30Mbps/3Mbps" \
    new-connection-mark="55. EU_Home_30Mbps/3Mbps_Connection" \
    src-address-list="55. EU_Home_30Mbps/3Mbps"
add action=mark-packet chain=prerouting comment=\
    "Mark Packets For Upload - 55. EU_Home_30Mbps/3Mbps_Upload" \
    connection-mark="55. EU_Home_30Mbps/3Mbps_Connection" new-packet-mark=\
    "55. EU_Home_30Mbps/3Mbps_Upload" passthrough=no src-address-list=\
    "55. EU_Home_30Mbps/3Mbps"
add action=mark-packet chain=prerouting comment=\
    "Mark Packets For Downloading - 55. EU_Home_30Mbps/3Mbps_Download" \
    connection-mark="55. EU_Home_30Mbps/3Mbps_Connection" dst-address-list=\
    "55. EU_Home_30Mbps/3Mbps" new-packet-mark=\
    "55. EU_Home_30Mbps/3Mbps_Download" passthrough=no
add action=mark-packet chain=postrouting comment=\
    "Mark Packets For Downloading - NAT 55. EU_Home_30Mbps/3Mbps_Download" \
    connection-mark="55. EU_Home_30Mbps/3Mbps_Connection" dst-address-list=\
    "55. EU_Home_30Mbps/3Mbps" new-packet-mark=\
    "55. EU_Home_30Mbps/3Mbps_Download" passthrough=no
add action=mark-connection chain=prerouting comment=\
    "Mark Connections For Queue Trees - 100. EU_BridgeHolder_15Mbps/5Mbps" \
    new-connection-mark="100. EU_BridgeHolder_15Mbps/5Mbps_Connection" \
    src-address-list="100. EU_BridgeHolder_15Mbps/5Mbps"
add action=mark-connection chain=postrouting comment=\
    "Mark Connections For Queue Trees - 100. EU_BridgeHolder_15Mbps/5Mbps" \
    new-connection-mark="100. EU_BridgeHolder_15Mbps/5Mbps_Connection" \
    src-address-list="100. EU_BridgeHolder_15Mbps/5Mbps"
add action=mark-packet chain=prerouting comment="Mark Packets For Upload - 100\
    . EU_BridgeHolder_15Mbps/5Mbps_Traffic-Upload" connection-mark=\
    "100. EU_BridgeHolder_15Mbps/5Mbps_Connection" new-packet-mark=\
    "100. EU_BridgeHolder_15Mbps/5Mbps_Traffic-Upload" passthrough=no \
    src-address-list="100. EU_BridgeHolder_15Mbps/5Mbps"
add action=mark-packet chain=prerouting comment="Mark Packets For Downloading \
    - 100. EU_BridgeHolder_15Mbps/5Mbps_Traffic-Download" connection-mark=\
    "100. EU_BridgeHolder_15Mbps/5Mbps_Connection" dst-address-list=\
    "100. EU_BridgeHolder_15Mbps/5Mbps" new-packet-mark=\
    "100. EU_BridgeHolder_15Mbps/5Mbps_Traffic-Download" passthrough=no
add action=mark-packet chain=postrouting comment="Mark Packets For Downloading\
    \_- NAT 100. EU_BridgeHolder_15Mbps/5Mbps_Traffic-Download" \
    connection-mark="100. EU_BridgeHolder_15Mbps/5Mbps_Connection" \
    dst-address-list="100. EU_BridgeHolder_15Mbps/5Mbps" new-packet-mark=\
    "100. EU_BridgeHolder_15Mbps/5Mbps_Traffic-Download" passthrough=no
add action=mark-connection chain=prerouting comment=\
    "Mark Connections For Queue Trees - 53. EU_Home_10Mbps/1Mbps" \
    new-connection-mark="53. EU_Home_10Mbps/1Mbps_Connection" \
    src-address-list="53. EU_Home_10Mbps/1Mbps"
add action=mark-connection chain=postrouting comment=\
    "Mark Connections For Queue Trees - 53. EU_Home_10Mbps/1Mbps" \
    new-connection-mark="53. EU_Home_10Mbps/1Mbps_Connection" \
    src-address-list="53. EU_Home_10Mbps/1Mbps"
add action=mark-packet chain=prerouting comment=\
    "Mark Packets For Upload - 53. EU_Home_10Mbps/1Mbps_Upload" \
    connection-mark="53. EU_Home_10Mbps/1Mbps_Connection" new-packet-mark=\
    "53. EU_Home_10Mbps/1Mbps_Upload" passthrough=no src-address-list=\
    "53. EU_Home_10Mbps/1Mbps"
add action=mark-packet chain=prerouting comment=\
    "Mark Packets For Downloading - 53. EU_Home_10Mbps/1Mbps_Download" \
    connection-mark="53. EU_Home_10Mbps/1Mbps_Connection" dst-address-list=\
    "53. EU_Home_10Mbps/1Mbps" new-packet-mark=\
    "53. EU_Home_10Mbps/1Mbps_Download" passthrough=no
add action=mark-packet chain=postrouting comment=\
    "Mark Packets For Downloading - NAT 53. EU_Home_10Mbps/1Mbps_Download" \
    connection-mark="53. EU_Home_10Mbps/1Mbps_Connection" dst-address-list=\
    "53. EU_Home_10Mbps/1Mbps" new-packet-mark=\
    "53. EU_Home_10Mbps/1Mbps_Download" passthrough=no
add action=mark-connection chain=prerouting comment=\
    "Mark Connections For Queue Trees - 54. EU_Home_8Mbps/3Mbps" \
    new-connection-mark="54. EU_Home_8Mbps/3Mbps_Connection" \
    src-address-list="54. EU_Home_8Mbps/3Mbps"
add action=mark-connection chain=postrouting comment=\
    "Mark Connections For Queue Trees - 54. EU_Home_8Mbps/3Mbps" \
    new-connection-mark="54. EU_Home_8Mbps/3Mbps_Connection" \
    src-address-list="54. EU_Home_8Mbps/3Mbps"
add action=mark-packet chain=prerouting comment=\
    "Mark Packets For Upload - 54. EU_Home_8Mbps/3Mbps-Upload" \
    connection-mark="54. EU_Home_8Mbps/3Mbps_Connection" new-packet-mark=\
    "54. EU_Home_8Mbps/3Mbps-Upload" passthrough=no src-address-list=\
    "54. EU_Home_8Mbps/3Mbps"
add action=mark-packet chain=prerouting comment=\
    "Mark Packets For Downloading - 54. EU_Home_8Mbps/3Mbps-Download" \
    connection-mark="54. EU_Home_8Mbps/3Mbps_Connection" dst-address-list=\
    "54. EU_Home_8Mbps/3Mbps" new-packet-mark=\
    "54. EU_Home_8Mbps/3Mbps-Download" passthrough=no
add action=mark-packet chain=postrouting comment=\
    "Mark Packets For Downloading - NAT 54. EU_Home_8Mbps/3Mbps-Download" \
    connection-mark="54. EU_Home_8Mbps/3Mbps_Connection" dst-address-list=\
    "54. EU_Home_8Mbps/3Mbps" new-packet-mark=\
    "54. EU_Home_8Mbps/3Mbps-Download" passthrough=no

	
	
	
	

If this post helped. Consider donating to my bit coin fund

1DrTMxNmBuZwgEcJs2LTh3hnB6VFEC1Uqf
User avatar
ukzerosniper
Posts: 28
Joined: Sat Jul 30, 2016 6:46 pm
Location: England
Contact:

Thu May 03, 2018 4:30 pm

I couldn't insert the whole code for the config push so I have cut it in half and posted the second chunk here.

Code: Select all

add action=mark-connection chain=prerouting comment=\
    "Mark Connections For Queue Trees - 52. EU_Home_7.5Mbps/750Kbps" \
    new-connection-mark="52. EU_Home_7.5Mbps/750Kbps_Connection" \
    src-address-list="52. EU_Home_7.5Mbps/750Kbps"
add action=mark-connection chain=postrouting comment=\
    "Mark Connections For Queue Trees - 52. EU_Home_7.5Mbps/750Kbps" \
    new-connection-mark="52. EU_Home_7.5Mbps/750Kbps_Connection" \
    src-address-list="52. EU_Home_7.5Mbps/750Kbps"
add action=mark-packet chain=prerouting comment=\
    "Mark Packets For Upload - 52. EU_Home_7.5Mbps/750Kbps_Upload" \
    connection-mark="52. EU_Home_7.5Mbps/750Kbps_Connection" new-packet-mark=\
    "52. EU_Home_7.5Mbps/750Kbps_Upload" passthrough=no src-address-list=\
    "52. EU_Home_7.5Mbps/750Kbps"
add action=mark-packet chain=prerouting comment=\
    "Mark Packets For Downloading - 52. EU_Home_7.5Mbps/750Kbps_Download" \
    connection-mark="52. EU_Home_7.5Mbps/750Kbps_Connection" \
    dst-address-list="52. EU_Home_7.5Mbps/750Kbps" new-packet-mark=\
    "52. EU_Home_7.5Mbps/750Kbps_Download" passthrough=no
add action=mark-packet chain=postrouting comment=\
    "Mark Packets For Downloading - NAT 52. EU_Home_7.5Mbps/750Kbps_Download" \
    connection-mark="52. EU_Home_7.5Mbps/750Kbps_Connection" \
    dst-address-list="52. EU_Home_7.5Mbps/750Kbps" new-packet-mark=\
    "52. EU_Home_7.5Mbps/750Kbps_Download" passthrough=no
add action=mark-connection chain=prerouting comment=\
    "Mark Connections For Queue Trees - 51. EU_Home_5Mbps/512Kbps" \
    new-connection-mark="51. EU_Home_5Mbps/512Kbps_Connection" \
    src-address-list="51. EU_Home_5Mbps/512Kbps"
add action=mark-connection chain=postrouting comment=\
    "Mark Connections For Queue Trees - 51. EU_Home_5Mbps/512Kbps" \
    new-connection-mark="51. EU_Home_5Mbps/512Kbps_Connection" \
    src-address-list="51. EU_Home_5Mbps/512Kbps"
add action=mark-packet chain=prerouting comment=\
    "Mark Packets For Upload - 51. EU_Home_5Mbps/512Kbps_Upload" \
    connection-mark="51. EU_Home_5Mbps/512Kbps_Connection" new-packet-mark=\
    "51. EU_Home_5Mbps/512Kbps_Upload" passthrough=no src-address-list=\
    "51. EU_Home_5Mbps/512Kbps"
add action=mark-packet chain=prerouting comment=\
    "Mark Packets For Downloading - 51. EU_Home_5Mbps/512Kbps_Download" \
    connection-mark="51. EU_Home_5Mbps/512Kbps_Connection" dst-address-list=\
    "51. EU_Home_5Mbps/512Kbps" new-packet-mark=\
    "51. EU_Home_5Mbps/512Kbps_Download" passthrough=no
add action=mark-packet chain=postrouting comment=\
    "Mark Packets For Downloading - NAT 51. EU_Home_5Mbps/512Kbps_Download" \
    connection-mark="51. EU_Home_5Mbps/512Kbps_Connection" dst-address-list=\
    "51. EU_Home_5Mbps/512Kbps" new-packet-mark=\
    "51. EU_Home_5Mbps/512Kbps_Download" passthrough=no
add action=mark-connection chain=prerouting comment=\
    "Mark Connections For Queue Trees - 50. EU_Home_2.5Mbps/0.5Kbps" \
    new-connection-mark="50. EU_Home_2.5Mbps/0.5Kbps_Connection" \
    src-address-list="50. EU_Home_2.5Mbps/0.5Kbps"
add action=mark-connection chain=postrouting comment=\
    "Mark Connections For Queue Trees - 50. EU_Home_2.5Mbps/0.5Kbps" \
    new-connection-mark="50. EU_Home_2.5Mbps/0.5Kbps_Connection" \
    src-address-list="50. EU_Home_2.5Mbps/0.5Kbps"
add action=mark-packet chain=prerouting comment=\
    "Mark Packets For Upload - 50. EU_Home_2.5Mbps/0.5Kbps_Upload" \
    connection-mark="50. EU_Home_2.5Mbps/0.5Kbps_Connection" new-packet-mark=\
    "50. EU_Home_2.5Mbps/0.5Kbps_Upload" passthrough=no src-address-list=\
    "50. EU_Home_2.5Mbps/0.5Kbps"
add action=mark-packet chain=prerouting comment=\
    "Mark Packets For Downloading - 50. EU_Home_2.5Mbps/0.5Kbps_Download" \
    connection-mark="50. EU_Home_2.5Mbps/0.5Kbps_Connection" \
    dst-address-list="50. EU_Home_2.5Mbps/0.5Kbps" new-packet-mark=\
    "50. EU_Home_2.5Mbps/0.5Kbps_Download" passthrough=no
add action=mark-packet chain=postrouting comment=\
    "Mark Packets For Downloading - NAT 50. EU_Home_2.5Mbps/0.5Kbps_Download" \
    connection-mark="50. EU_Home_2.5Mbps/0.5Kbps_Connection" \
    dst-address-list="50. EU_Home_2.5Mbps/0.5Kbps" new-packet-mark=\
    "50. EU_Home_2.5Mbps/0.5Kbps_Download" passthrough=no
add action=mark-connection chain=prerouting comment="Mark Connections For Queue Trees - 27. EU_Business_80Mbps/40Mbps" new-connection-mark="27. EU_Business_80Mbps/40Mbps_Connection" src-address-list="27. EU_Business_80Mbps/40Mbps"
add action=mark-connection chain=postrouting comment="Mark Connections For Queue Trees - 27. EU_Business_80Mbps/40Mbps" new-connection-mark="27. EU_Business_80Mbps/40Mbps_Connection" src-address-list="27. EU_Business_80Mbps/40Mbps"
add action=mark-packet chain=prerouting comment="Mark Packets For Upload - 27. EU_Business_80Mbps/40Mbps-Upload" connection-mark="27. EU_Business_80Mbps/40Mbps_Connection" new-packet-mark="27. EU_Business_80Mbps/40Mbps-Upload" passthrough=no src-address-list="27. EU_Business_80Mbps/40Mbps"
add action=mark-packet chain=prerouting comment="Mark Packets For Downloading - 27. EU_Business_80Mbps/40Mbps-Download" connection-mark="27. EU_Business_80Mbps/40Mbps_Connection" dst-address-list="27. EU_Business_80Mbps/40Mbps" new-packet-mark="27. EU_Business_80Mbps/40Mbps-Download" passthrough=no
add action=mark-packet chain=postrouting comment="Mark Packets For Downloading - NAT 27. EU_Business_80Mbps/40Mbps-Download" connection-mark="27. EU_Business_80Mbps/40Mbps_Connection" dst-address-list="27. EU_Business_80Mbps/40Mbps" new-packet-mark="27. EU_Business_80Mbps/40Mbps-Download" passthrough=no
add action=mark-connection chain=prerouting comment="Mark Connections For Queue Trees - 26. EU_Business_50Mbps/5Mbps" new-connection-mark="26. EU_Business_50Mbps/5Mbps_Connection" src-address-list="26. EU_Business_50Mbps/5Mbps"
add action=mark-connection chain=postrouting comment="Mark Connections For Queue Trees - 26. EU_Business_50Mbps/5Mbps" new-connection-mark="26. EU_Business_50Mbps/5Mbps_Connection" src-address-list="26. EU_Business_50Mbps/5Mbps"
add action=mark-packet chain=prerouting comment="Mark Packets For Upload - 26. EU_Business_50Mbps/5Mbps-Upload" connection-mark="26. EU_Business_50Mbps/5Mbps_Connection" new-packet-mark="26. EU_Business_50Mbps/5Mbps-Upload" passthrough=no src-address-list="26. EU_Business_50Mbps/5Mbps"
add action=mark-packet chain=prerouting comment="Mark Packets For Downloading - 26. EU_Business_50Mbps/5Mbps-Download" connection-mark="26. EU_Business_50Mbps/5Mbps_Connection" dst-address-list="26. EU_Business_50Mbps/5Mbps" new-packet-mark="26. EU_Business_50Mbps/5Mbps-Download" passthrough=no
add action=mark-packet chain=postrouting comment="Mark Packets For Downloading - NAT 26. EU_Business_50Mbps/5Mbps-Download" connection-mark="26. EU_Business_50Mbps/5Mbps_Connection" dst-address-list="26. EU_Business_50Mbps/5Mbps" new-packet-mark="26. EU_Business_50Mbps/5Mbps-Download" passthrough=no
add action=mark-connection chain=prerouting comment="Mark Connections For Queue Trees - 25. EU_Business_30Mbps/3Mbps" new-connection-mark="25. EU_Business_30Mbps/3Mbps_Connection" src-address-list="25. EU_Business_30Mbps/3Mbps"
add action=mark-connection chain=postrouting comment="Mark Connections For Queue Trees - 25. EU_Business_30Mbps/3Mbps" new-connection-mark="25. EU_Business_30Mbps/3Mbps_Connection" src-address-list="25. EU_Business_30Mbps/3Mbps"
add action=mark-packet chain=prerouting comment="Mark Packets For Upload - 25. EU_Business_30Mbps/3Mbps-Upload" connection-mark="25. EU_Business_30Mbps/3Mbps_Connection" new-packet-mark="25. EU_Business_30Mbps/3Mbps-Upload" passthrough=no src-address-list="25. EU_Business_30Mbps/3Mbps"
add action=mark-packet chain=prerouting comment="Mark Packets For Downloading - 25. EU_Business_30Mbps/3Mbps-Download" connection-mark="25. EU_Business_30Mbps/3Mbps_Connection" dst-address-list="25. EU_Business_30Mbps/3Mbps" new-packet-mark="25. EU_Business_30Mbps/3Mbps-Download" passthrough=no
add action=mark-packet chain=postrouting comment="Mark Packets For Downloading - NAT 25. EU_Business_30Mbps/3Mbps-Download" connection-mark="25. EU_Business_30Mbps/3Mbps_Connection" dst-address-list="25. EU_Business_30Mbps/3Mbps" new-packet-mark="25. EU_Business_30Mbps/3Mbps-Download" passthrough=no
add action=mark-connection chain=prerouting comment="Mark Connections For Queue Trees - 24. EU_Business_15Mbps/5Mbps" new-connection-mark="24. EU_Business_15Mbps/5Mbps_Connection" src-address-list="24. EU_Business_15Mbps/5Mbps"
add action=mark-connection chain=postrouting comment="Mark Connections For Queue Trees - 24. EU_Business_15Mbps/5Mbps" new-connection-mark="24. EU_Business_15Mbps/5Mbps_Connection" src-address-list="24. EU_Business_15Mbps/5Mbps"
add action=mark-packet chain=prerouting comment="Mark Packets For Upload - 24. EU_Business_15Mbps/5Mbps-Upload" connection-mark="24. EU_Business_15Mbps/5Mbps_Connection" new-packet-mark="24. EU_Business_15Mbps/5Mbps-Upload" passthrough=no src-address-list="24. EU_Business_15Mbps/5Mbps"
add action=mark-packet chain=prerouting comment="Mark Packets For Downloading - 24. EU_Business_15Mbps/5Mbps-Download" connection-mark="24. EU_Business_15Mbps/5Mbps_Connection" dst-address-list="24. EU_Business_15Mbps/5Mbps" new-packet-mark="24. EU_Business_15Mbps/5Mbps-Download" passthrough=no
add action=mark-packet chain=postrouting comment="Mark Packets For Downloading - NAT 24. EU_Business_15Mbps/5Mbps-Download" connection-mark="24. EU_Business_15Mbps/5Mbps_Connection" dst-address-list="24. EU_Business_15Mbps/5Mbps" new-packet-mark="24. EU_Business_15Mbps/5Mbps-Download" passthrough=no
add action=mark-connection chain=prerouting comment=\
    "Mark Connections For Queue Trees - 23. EU_Business_10Mbps/1Mbps" \
    new-connection-mark="23. EU_Business_10Mbps/1Mbps_Connection" \
    src-address-list="23. EU_Business_10Mbps/1Mbps"
add action=mark-connection chain=postrouting comment=\
    "Mark Connections For Queue Trees - 23. EU_Business_10Mbps/1Mbps" \
    new-connection-mark="23. EU_Business_10Mbps/1Mbps_Connection" \
    src-address-list="23. EU_Business_10Mbps/1Mbps"
add action=mark-packet chain=prerouting comment=\
    "Mark Packets For Upload - 23. EU_Business_10Mbps/1Mbps-Upload" \
    connection-mark="23. EU_Business_10Mbps/1Mbps_Connection" \
    new-packet-mark="23. EU_Business_10Mbps/1Mbps-Upload" passthrough=no \
    src-address-list="23. EU_Business_10Mbps/1Mbps"
add action=mark-packet chain=prerouting comment=\
    "Mark Packets For Downloading - 23. EU_Business_10Mbps/1Mbps-Download" \
    connection-mark="23. EU_Business_10Mbps/1Mbps_Connection" \
    dst-address-list="23. EU_Business_10Mbps/1Mbps" new-packet-mark=\
    "23. EU_Business_10Mbps/1Mbps-Download" passthrough=no
add action=mark-packet chain=postrouting comment="Mark Packets For Downloading\
    \_- NAT 23. EU_Business_10Mbps/1Mbps-Download" connection-mark=\
    "23. EU_Business_10Mbps/1Mbps_Connection" dst-address-list=\
    "23. EU_Business_10Mbps/1Mbps" new-packet-mark=\
    "23. EU_Business_10Mbps/1Mbps-Download" passthrough=no
add action=mark-connection chain=prerouting comment=\
    "Mark Connections For Queue Trees - 22. EU_Business_7.5Mbps/750Kbps" \
    new-connection-mark="22. EU_Business_7.5Mbps/750Kbps_Connection" \
    src-address-list="22. EU_Business_7.5Mbps/750Kbps"
add action=mark-connection chain=postrouting comment=\
    "Mark Connections For Queue Trees - 22. EU_Business_7.5Mbps/750Kbps" \
    new-connection-mark="22. EU_Business_7.5Mbps/750Kbps_Connection" \
    src-address-list="22. EU_Business_7.5Mbps/750Kbps"
add action=mark-packet chain=prerouting comment=\
    "Mark Packets For Upload - 22. EU_Business_7.5Mbps/750Kbps-Upload" \
    connection-mark="22. EU_Business_7.5Mbps/750Kbps_Connection" \
    new-packet-mark="22. EU_Business_7.5Mbps/750Kbps-Upload" passthrough=no \
    src-address-list="22. EU_Business_7.5Mbps/750Kbps"
add action=mark-packet chain=prerouting comment=\
    "Mark Packets For Downloading - 22. EU_Business_7.5Mbps/750Kbps-Download" \
    connection-mark="22. EU_Business_7.5Mbps/750Kbps_Connection" \
    dst-address-list="22. EU_Business_7.5Mbps/750Kbps" new-packet-mark=\
    "22. EU_Business_7.5Mbps/750Kbps-Download" passthrough=no
add action=mark-packet chain=postrouting comment="Mark Packets For Downloading\
    \_- NAT 22. EU_Business_7.5Mbps/750Kbps-Download" connection-mark=\
    "22. EU_Business_7.5Mbps/750Kbps_Connection" dst-address-list=\
    "22. EU_Business_7.5Mbps/750Kbps" new-packet-mark=\
    "22. EU_Business_7.5Mbps/750Kbps-Download" passthrough=no
add action=mark-connection chain=prerouting comment=\
    "Mark Connections For Queue Trees - 21. EU_Business_5.0Mbps/512Kbps" \
    new-connection-mark="21. EU_Business_5.0Mbps/512Kbps_Connection" \
    src-address-list="21. EU_Business_5.0Mbps/512Kbps"
add action=mark-connection chain=postrouting comment=\
    "Mark Connections For Queue Trees - 21. EU_Business_5.0Mbps/512Kbps" \
    new-connection-mark="21. EU_Business_5.0Mbps/512Kbps_Connection" \
    src-address-list="21. EU_Business_5.0Mbps/512Kbps"
add action=mark-packet chain=prerouting comment=\
    "Mark Packets For Upload - 21. EU_Business_5.0Mbps/512Kbps-Upload" \
    connection-mark="21. EU_Business_5.0Mbps/512Kbps_Connection" \
    new-packet-mark="21. EU_Business_5.0Mbps/512Kbps-Upload" passthrough=no \
    src-address-list="21. EU_Business_5.0Mbps/512Kbps"
add action=mark-packet chain=prerouting comment=\
    "Mark Packets For Downloading - 21. EU_Business_5.0Mbps/512Kbps-Download" \
    connection-mark="21. EU_Business_5.0Mbps/512Kbps_Connection" \
    dst-address-list="21. EU_Business_5.0Mbps/512Kbps" new-packet-mark=\
    "21. EU_Business_5.0Mbps/512Kbps-Download" passthrough=no
add action=mark-packet chain=postrouting comment="Mark Packets For Downloading\
    \_- NAT 21. EU_Business_5.0Mbps/512Kbps-Download" connection-mark=\
    "21. EU_Business_5.0Mbps/512Kbps_Connection" dst-address-list=\
    "21. EU_Business_5.0Mbps/512Kbps" new-packet-mark=\
    "21. EU_Business_5.0Mbps/512Kbps-Download" passthrough=no
add action=mark-connection chain=prerouting comment=\
    "Mark Connections For Queue Trees - 20. EU_Business_2.5Mbps/0.5Kbps" \
    new-connection-mark="20. EU_Business_2.5Mbps/0.5Kbps_Connection" \
    src-address-list="20. EU_Business_2.5Mbps/0.5Kbps"
add action=mark-connection chain=postrouting comment=\
    "Mark Connections For Queue Trees - 20. EU_Business_2.5Mbps/0.5Kbps" \
    new-connection-mark="20. EU_Business_2.5Mbps/0.5Kbps_Connection" \
    src-address-list="20. EU_Business_2.5Mbps/0.5Kbps"
add action=mark-packet chain=prerouting comment=\
    "Mark Packets For Upload - 20. EU_Business_2.5Mbps/0.5Kbps-Upload" \
    connection-mark="20. EU_Business_2.5Mbps/0.5Kbps_Connection" \
    new-packet-mark="20. EU_Business_2.5Mbps/0.5Kbps-Upload" passthrough=no \
    src-address-list="20. EU_Business_2.5Mbps/0.5Kbps"
add action=mark-packet chain=prerouting comment=\
    "Mark Packets For Downloading - 20. EU_Business_2.5Mbps/0.5Kbps-Download" \
    connection-mark="20. EU_Business_2.5Mbps/0.5Kbps_Connection" \
    dst-address-list="20. EU_Business_2.5Mbps/0.5Kbps" new-packet-mark=\
    "20. EU_Business_2.5Mbps/0.5Kbps-Download" passthrough=no
add action=mark-packet chain=postrouting comment="Mark Packets For Downloading\
    \_- NAT 20. EU_Business_2.5Mbps/0.5Kbps-Download" connection-mark=\
    "20. EU_Business_2.5Mbps/0.5Kbps_Connection" dst-address-list=\
    "20. EU_Business_2.5Mbps/0.5Kbps" new-packet-mark=\
    "20. EU_Business_2.5Mbps/0.5Kbps-Download" passthrough=no
add action=mark-connection chain=prerouting comment=\
    "Mark Connections For Queue Trees - 6. EU_Business_Symm_20Mbps/20Mbps" \
    new-connection-mark="6. EU_Business_Symm_20Mbps/20Mbps_Connection" \
    src-address-list="6. EU_Business_Symm_20Mbps/20Mbps"
add action=mark-connection chain=postrouting comment=\
    "Mark Connections For Queue Trees - 6. EU_Business_Symm_20Mbps/20Mbps" \
    new-connection-mark="6. EU_Business_Symm_20Mbps/20Mbps_Connection" \
    src-address-list="6. EU_Business_Symm_20Mbps/20Mbps"
add action=mark-packet chain=prerouting comment=\
    "Mark Packets For Upload - 6. EU_Business_Symm_20Mbps/20Mbps-Upload" \
    connection-mark="6. EU_Business_Symm_20Mbps/20Mbps_Connection" \
    new-packet-mark="6. EU_Business_Symm_20Mbps/20Mbps-Upload" passthrough=no \
    src-address-list="6. EU_Business_Symm_20Mbps/20Mbps"
add action=mark-packet chain=prerouting comment="Mark Packets For Downloading \
    - 6. EU_Business_Symm_20Mbps/20Mbps-Download" connection-mark=\
    "6. EU_Business_Symm_20Mbps/20Mbps_Connection" dst-address-list=\
    "6. EU_Business_Symm_20Mbps/20Mbps" new-packet-mark=\
    "6. EU_Business_Symm_20Mbps/20Mbps-Download" passthrough=no
add action=mark-packet chain=postrouting comment="Mark Packets For Downloading\
    \_- NAT 6. EU_Business_Symm_20Mbps/20Mbps-Download" connection-mark=\
    "6. EU_Business_Symm_20Mbps/20Mbps_Connection" dst-address-list=\
    "6. EU_Business_Symm_20Mbps/20Mbps" new-packet-mark=\
    "6. EU_Business_Symm_20Mbps/20Mbps-Download" passthrough=no
add action=mark-connection chain=prerouting comment=\
    "Mark Connections For Queue Trees - 5. EU_Business_Symm_15Mbps/15Mbps" \
    new-connection-mark="5. EU_Business_Symm_15Mbps/15Mbps_Connection" \
    src-address-list="5. EU_Business_Symm_15Mbps/15Mbps"
add action=mark-connection chain=postrouting comment=\
    "Mark Connections For Queue Trees - 5. EU_Business_Symm_15Mbps/15Mbps" \
    new-connection-mark="5. EU_Business_Symm_15Mbps/15Mbps_Connection" \
    src-address-list="5. EU_Business_Symm_15Mbps/15Mbps"
add action=mark-packet chain=prerouting comment=\
    "Mark Packets For Upload - 5. EU_Business_Symm_15Mbps/15Mbps-Upload" \
    connection-mark="5. EU_Business_Symm_15Mbps/15Mbps_Connection" \
    new-packet-mark="5. EU_Business_Symm_15Mbps/15Mbps-Upload" passthrough=no \
    src-address-list="5. EU_Business_Symm_15Mbps/15Mbps"
add action=mark-packet chain=prerouting comment="Mark Packets For Downloading \
    - 5. EU_Business_Symm_15Mbps/15Mbps-Download" connection-mark=\
    "5. EU_Business_Symm_15Mbps/15Mbps_Connection" dst-address-list=\
    "5. EU_Business_Symm_15Mbps/15Mbps" new-packet-mark=\
    "5. EU_Business_Symm_15Mbps/15Mbps-Download" passthrough=no
add action=mark-packet chain=postrouting comment="Mark Packets For Downloading\
    \_- NAT 5. EU_Business_Symm_15Mbps/15Mbps-Download" connection-mark=\
    "5. EU_Business_Symm_15Mbps/15Mbps_Connection" dst-address-list=\
    "5. EU_Business_Symm_15Mbps/15Mbps" new-packet-mark=\
    "5. EU_Business_Symm_15Mbps/15Mbps-Download" passthrough=no
add action=mark-connection chain=prerouting comment=\
    "Mark Connections For Queue Trees - 4. EU_Business_Symm_10Mbps/10Mbps" \
    new-connection-mark="4. EU_Business_Symm_10Mbps/10Mbps_Connection" \
    src-address-list="4. EU_Business_Symm_10Mbps/10Mbps"
add action=mark-connection chain=postrouting comment=\
    "Mark Connections For Queue Trees - 4. EU_Business_Symm_10Mbps/10Mbps" \
    new-connection-mark="4. EU_Business_Symm_10Mbps/10Mbps_Connection" \
    src-address-list="4. EU_Business_Symm_10Mbps/10Mbps"
add action=mark-packet chain=prerouting comment=\
    "Mark Packets For Upload - 4. EU_Business_Symm_10Mbps/10Mbps-Upload" \
    connection-mark="4. EU_Business_Symm_10Mbps/10Mbps_Connection" \
    new-packet-mark="4. EU_Business_Symm_10Mbps/10Mbps-Upload" passthrough=no \
    src-address-list="4. EU_Business_Symm_10Mbps/10Mbps"
add action=mark-packet chain=prerouting comment="Mark Packets For Downloading \
    - 4. EU_Business_Symm_10Mbps/10Mbps-Download" connection-mark=\
    "4. EU_Business_Symm_10Mbps/10Mbps_Connection" dst-address-list=\
    "4. EU_Business_Symm_10Mbps/10Mbps" new-packet-mark=\
    "4. EU_Business_Symm_10Mbps/10Mbps-Download" passthrough=no
add action=mark-packet chain=postrouting comment="Mark Packets For Downloading\
    \_- NAT 4. EU_Business_Symm_10Mbps/10Mbps-Download" connection-mark=\
    "4. EU_Business_Symm_10Mbps/10Mbps_Connection" dst-address-list=\
    "4. EU_Business_Symm_10Mbps/10Mbps" new-packet-mark=\
    "4. EU_Business_Symm_10Mbps/10Mbps-Download" passthrough=no
add action=mark-connection chain=prerouting comment=\
    "Mark Connections For Queue Trees - 3. EU_Business_Symm_7.5Mbps/7.5Mbps" \
    new-connection-mark="3. EU_Business_Symm_7.5Mbps/7.5Mbps_Connection" \
    src-address-list="3. EU_Business_Symm_7.5Mbps/7.5Mbps"
add action=mark-connection chain=postrouting comment=\
    "Mark Connections For Queue Trees - 3. EU_Business_Symm_7.5Mbps/7.5Mbps" \
    new-connection-mark="3. EU_Business_Symm_7.5Mbps/7.5Mbps_Connection" \
    src-address-list="3. EU_Business_Symm_7.5Mbps/7.5Mbps"
add action=mark-packet chain=prerouting comment=\
    "Mark Packets For Upload - 3. EU_Business_Symm_7.5Mbps/7.5Mbps-Upload" \
    connection-mark="3. EU_Business_Symm_7.5Mbps/7.5Mbps_Connection" \
    new-packet-mark="3. EU_Business_Symm_7.5Mbps/7.5Mbps-Upload" passthrough=\
    no src-address-list="3. EU_Business_Symm_7.5Mbps/7.5Mbps"
add action=mark-packet chain=prerouting comment="Mark Packets For Downloading \
    - 3. EU_Business_Symm_7.5Mbps/7.5Mbps-Download" connection-mark=\
    "3. EU_Business_Symm_7.5Mbps/7.5Mbps_Connection" dst-address-list=\
    "3. EU_Business_Symm_7.5Mbps/7.5Mbps" new-packet-mark=\
    "3. EU_Business_Symm_7.5Mbps/7.5Mbps-Download" passthrough=no
add action=mark-packet chain=postrouting comment="Mark Packets For Downloading\
    \_- NAT 3. EU_Business_Symm_7.5Mbps/7.5Mbps-Download" connection-mark=\
    "3. EU_Business_Symm_7.5Mbps/7.5Mbps_Connection" dst-address-list=\
    "3. EU_Business_Symm_7.5Mbps/7.5Mbps" new-packet-mark=\
    "3. EU_Business_Symm_7.5Mbps/7.5Mbps-Download" passthrough=no
add action=mark-connection chain=prerouting comment=\
    "Mark Connections For Queue Trees - 2. EU_Business_Symm_5Mbps/5Mbps" \
    new-connection-mark="2. EU_Business_Symm_5Mbps/5Mbps_Connection" \
    src-address-list="2. EU_Business_Symm_5Mbps/5Mbps"
add action=mark-connection chain=postrouting comment=\
    "Mark Connections For Queue Trees - 2. EU_Business_Symm_5Mbps/5Mbps" \
    new-connection-mark="2. EU_Business_Symm_5Mbps/5Mbps_Connection" \
    src-address-list="2. EU_Business_Symm_5Mbps/5Mbps"
add action=mark-packet chain=prerouting comment=\
    "Mark Packets For Upload - 2. EU_Business_Symm_5Mbps/5Mbps-Upload" \
    connection-mark="2. EU_Business_Symm_5Mbps/5Mbps_Connection" \
    new-packet-mark="2. EU_Business_Symm_5Mbps/5Mbps-Upload" passthrough=no \
    src-address-list="2. EU_Business_Symm_5Mbps/5Mbps"
add action=mark-packet chain=prerouting comment=\
    "Mark Packets For Downloading - 2. EU_Business_Symm_5Mbps/5Mbps-Download" \
    connection-mark="2. EU_Business_Symm_5Mbps/5Mbps_Connection" \
    dst-address-list="2. EU_Business_Symm_5Mbps/5Mbps" new-packet-mark=\
    "2. EU_Business_Symm_5Mbps/5Mbps-Download" passthrough=no
add action=mark-packet chain=postrouting comment="Mark Packets For Downloading\
    \_- NAT 2. EU_Business_Symm_5Mbps/5Mbps-Download" connection-mark=\
    "2. EU_Business_Symm_5Mbps/5Mbps_Connection" dst-address-list=\
    "2. EU_Business_Symm_5Mbps/5Mbps" new-packet-mark=\
    "2. EU_Business_Symm_5Mbps/5Mbps-Download" passthrough=no
add action=mark-connection chain=prerouting comment=\
    "Mark Connections For Queue Trees - 1. EU_Business_Symm_2.5Mbps/2.5Mbps" \
    new-connection-mark="1. EU_Business_Symm_2.5Mbps/2.5Mbps_Connection" \
    src-address-list="1. EU_Business_Symm_2.5Mbps/2.5Mbps"
add action=mark-connection chain=postrouting comment=\
    "Mark Connections For Queue Trees - 1. EU_Business_Symm_2.5Mbps/2.5Mbps" \
    new-connection-mark="1. EU_Business_Symm_2.5Mbps/2.5Mbps_Connection" \
    src-address-list="1. EU_Business_Symm_2.5Mbps/2.5Mbps"
add action=mark-packet chain=prerouting comment=\
    "Mark Packets For Upload - 1. EU_Business_Symm_2.5Mbps/2.5Mbps-Upload" \
    connection-mark="1. EU_Business_Symm_2.5Mbps/2.5Mbps_Connection" \
    new-packet-mark="1. EU_Business_Symm_2.5Mbps/2.5Mbps-Upload" passthrough=\
    no src-address-list="1. EU_Business_Symm_2.5Mbps/2.5Mbps"
add action=mark-packet chain=prerouting comment="Mark Packets For Downloading \
    - 1. EU_Business_Symm_2.5Mbps/2.5Mbps-Download" connection-mark=\
    "1. EU_Business_Symm_2.5Mbps/2.5Mbps_Connection" dst-address-list=\
    "1. EU_Business_Symm_2.5Mbps/2.5Mbps" new-packet-mark=\
    "1. EU_Business_Symm_2.5Mbps/2.5Mbps-Download" passthrough=no
add action=mark-packet chain=postrouting comment="Mark Packets For Downloading\
    \_- NAT 1. EU_Business_Symm_2.5Mbps/2.5Mbps-Download" connection-mark=\
    "1. EU_Business_Symm_2.5Mbps/2.5Mbps_Connection" dst-address-list=\
    "1. EU_Business_Symm_2.5Mbps/2.5Mbps" new-packet-mark=\
    "1. EU_Business_Symm_2.5Mbps/2.5Mbps-Download" passthrough=no
add action=mark-connection chain=prerouting comment=\
    "Mark Connections For Queue Trees - OFFICE_JHCS" new-connection-mark=\
    OFFICE_JHCS_Connection src-address-list=OFFICE_JHCS
add action=mark-connection chain=postrouting comment=\
    "Mark Connections For Queue Trees - OFFICE_JHCS" new-connection-mark=\
    OFFICE_JHCS_Connection src-address-list=OFFICE_JHCS
add action=mark-packet chain=prerouting comment=\
    "Mark Packets For Upload - OFFICE_JHCS_Traffic_Upload" connection-mark=\
    OFFICE_JHCS_Connection new-packet-mark=OFFICE_JHCS_Traffic_Upload \
    passthrough=no src-address-list=OFFICE_JHCS
add action=mark-packet chain=prerouting comment=\
    "Mark Packets For Downloading - OFFICE_JHCS_Traffic_Download" \
    connection-mark=OFFICE_JHCS_Connection dst-address-list=OFFICE_JHCS \
    new-packet-mark=OFFICE_JHCS_Traffic_Download passthrough=no
add action=mark-packet chain=postrouting comment=\
    "Mark Packets For Downloading - NAT OFFICE_JHCS_Traffic_Download" \
    connection-mark=OFFICE_JHCS_Connection dst-address-list=OFFICE_JHCS \
    new-packet-mark=OFFICE_JHCS_Traffic_Download passthrough=no
If this post helped. Consider donating to my bit coin fund

1DrTMxNmBuZwgEcJs2LTh3hnB6VFEC1Uqf
User avatar
Tomas
Posts: 561
Joined: Sat Jun 25, 2016 12:33 pm

Thu May 03, 2018 4:54 pm

Length of Commands is limited on the DB layer to 1000 characters, that is why it fails.

So I see 2 things that we need to do:
1) increase this limit to say 100k
2) better visibility for the user of this limit and better error message
User avatar
ukzerosniper
Posts: 28
Joined: Sat Jul 30, 2016 6:46 pm
Location: England
Contact:

Fri May 04, 2018 8:27 am

Yeah, the two modifications there would fully resolve the issue. Also, you mentioned you may need to look at Unimus's ability to comprehend Mikrotik line breaks.

When I have fully tested a config and i'm ready to push it out, ill often just export form the lab setup which will include line breaks in some cases. Id rather not have to sanitise it manually if possible.

The feature looks awesome, I cannot wait to try it in anger. I have hundreds of routers I want to mass configure :).
If this post helped. Consider donating to my bit coin fund

1DrTMxNmBuZwgEcJs2LTh3hnB6VFEC1Uqf
User avatar
Tomas
Posts: 561
Joined: Sat Jun 25, 2016 12:33 pm

Fri May 04, 2018 9:41 pm

Issues should be solved in 1.7.0-Beta4 (to be released tomorrow).

Command limit will be 65k characters (because thats a String VarChar limit for databases).
We have made the text area properly display an error, and the preset won't be saveable/runnable when there is more than 65k characters in it.
Post Reply