[Solved] Windows server minimum/recommended version?

General discussion of anything Unimus
Post Reply
nets
Posts: 5
Joined: Fri Nov 08, 2019 12:24 pm

Fri Jan 10, 2020 12:24 pm

I couldn't find it on the web or wiki. What is the minimum/recommended (Microsoft Windows) version for running latest Unimus (and 2.0 if possible)?
The reason i ask is that there are substantial differences between Windows Server versions. In regards to threading, network stack, memory organization etc.
User avatar
Tomas
Posts: 864
Joined: Sat Jun 25, 2016 12:33 pm

Fri Jan 10, 2020 2:10 pm

Hi,

Officially we support Windows Server 2012 R2 and any newer Win Server releases.
I personally would recommend Server 2016.

Other recommendations:
1) if deploying more than 200 devices in Unimus, do not use HSQL
A full-grade database is recommended (MySQL, MariaDB, PostgreSQL, etc.).
This is also documented in the Wiki sizing article: https://wiki.unimus.net/display/UNPUB/H ... quirements

2) if deploying more than 200 devices in Unimus, adjusting memory limits is needed:
Documentation available here: https://wiki.unimus.net/display/UNPUB/C ... mory+usage

3) If deploying 1000+ devices in Unimus, proper production-grade configuration of the DB server will be required.
(default configurations of DB engines lack a lot of production-grade settings, so adjustments are needed)

4) If deploying 1000+ devices in Unimus, we recommend running the server on Linux.
We do officially support Windows for deploys of this scale, but we do recommend Linux.

Hope this helps! :)
nets
Posts: 5
Joined: Fri Nov 08, 2019 12:24 pm

Mon Jan 20, 2020 11:13 am

This has been exactly what I've been looking for. My task was suddenly much more predictable.
Thank you!
Post Reply