[Fixed in 2.4.0] Zabbix Integration Import Error

Unimus support forum
Post Reply
elijahq
Posts: 1
Joined: Wed May 31, 2023 9:23 pm

Wed May 31, 2023 9:33 pm

Unimus Version - 2.3.3
Zabbix Version - 6.2.6

Running into issue trying to get the NMS sync to work for Zabbix. Keep getting "Import error: Failed to choose suitable client for API version 6.2.6". Have tried several different things to no avail any help would be appreciated.
User avatar
Tomas
Posts: 1194
Joined: Sat Jun 25, 2016 12:33 pm

Fri Jun 02, 2023 4:44 pm

Hello. Apologies for a delayed response. The devs analyzed our Zabbix sync code, and we have found the issue. Due to changes in the Zabbix API in 6.4 we changed our Zabbix connector in 2.3.3 (more info in the 2.3.3 changelog). This has sadly created a bug, where Unimus won't sync from Zabbix versions 6.2.1 and newer within 6.2.

Zabbix 6.2.0 and older will work. Zabbix 6.4.0 and newer will work too. The issue is only with the specific versions I mentioned.

We are fixing this ASAP, and the fix will be released in 2.4.0-Beta1, currently scheduled for the end of next week. I will update this topic as soon as the version with the fix is available.
dominik.c
Posts: 33
Joined: Fri Jun 09, 2023 6:47 pm

Tue Jun 13, 2023 8:37 pm

Hello, We have a new Unimus version 2.4.0-Beta1 live now, which also includes fixed NMS Sync from Zabbix versions 6.2.x.

viewtopic.php?f=4&t=1644

If you get a chance, give it a try and let us know if all worked as expected.
dominik.c
Posts: 33
Joined: Fri Jun 09, 2023 6:47 pm

Tue Dec 12, 2023 8:07 pm

Greetings, 
 
If you have been waiting for a stable release, we now have a Unimus version 2.4.0 live, where we fixed the issue with Remote Core reconnect to the Server in specific cases. Here's a link to our release post, which goes over all the work done on this release:

viewtopic.php?f=3&t=1701
https://wiki.unimus.net/pages/viewpage. ... d=36110338

If you get a chance, give it a try and let us know if all worked as expected.
Thank you
Post Reply