[Solved] Problems with discovery on LinkSys device ( SPS224G4 )

Unimus support forum
Post Reply
Posts: 1
Joined: Wed Oct 06, 2021 2:25 pm

Wed Oct 06, 2021 2:35 pm


We testing "unimus" for our infrastructure and faced with problem due SSH connection with an old device ( LinkSys SPS224G4 )
I think the problem is double login prompt through SSH which described here → https://community.cisco.com/t5/small-bu ... -p/4052533

Unimus says ​"SSH: CONNECTION_ERROR" and as this is an old revision of hardware - there is no way to disable these double login prompt on switch ( There is no option "ip ssh password-auth" in our case )
Any idea how to fix it ?
Posts: 123
Joined: Thu Aug 05, 2021 6:35 pm

Wed Oct 06, 2021 3:08 pm


We don't have a support for Linksys devices yet

https://wiki.unimus.net/pages/viewpage. ... d=10092755

but we would be happy to add a support for them.
Create a support ticket in our Portal, please, and we will get back to you with information necessary for the integration.
Posts: 123
Joined: Thu Aug 05, 2021 6:35 pm

Fri Oct 15, 2021 6:16 pm

As an update, we found out this device was using a non-standard diffie-hellman KEX key size of 1026.
Unimus supports only standard values in the range from 512 to 8192 in multiples of 64, so for example in this particular case a key size could be 1024.
Posts: 123
Joined: Thu Aug 05, 2021 6:35 pm

Thu Mar 24, 2022 8:56 pm

We have a new Unimus version 2.2.3-Beta1 live now, which contains a new SSH library which comes with improvements to compatibility with newer and stricter algorithms and some other encountered limitations like when a device used some non-standard key sizes for key exchange algorithms. You can find more information in our Beta branch thread


and download a new version below


If you get a chance, give it a try and let us know if it worked as expected, or if you encounter any other issue.
Post Reply