[Solved] Upgrade from 1.1.0x to 2.0.x

Unimus support forum
Post Reply
jvbac
Posts: 2
Joined: Thu Jan 28, 2021 5:40 pm

Thu Jan 28, 2021 5:50 pm

Hello,
We are trying to update to the latest ver. 2.0.10
However, we are getting an java error during the install process. (Windows 2019 Server)

"Failed to extract contents of c:\programs files\unimus\uninstall.exe\jre8.zip!"zipfldr.dll" most likely not available, error 2

Please extract the zip manually to c:\program files\unimus\uninstall.exe\jre8 before pressing ok"


We could not file the files to extract and had to hit ok to get out of the error
The installer seemed to finish, but Unimus is still on ver 1.1.04

Are we doing something wrong?

Also, during the upgrade, the path is going to c:\program files\unimus\uninstall.exe vs the root path of c:\program files\unimus\

At first i though tit was to start the uninstaller of the old version...but not sure now

thanks in advance!
User avatar
Tomas
Posts: 983
Joined: Sat Jun 25, 2016 12:33 pm

Thu Jan 28, 2021 6:43 pm

We have identified the issue - indeed upgrading from v1 to v2 using our Windows installer will result in this error.

You can fix this by properly setting the install path to "c:\program files\unimus" during the path selection step in the installer (the "\uninstaller.exe" is incorrectly appended there).

We are fixing this now, and will release an updated Installer version as soon as it's ready :)
jvbac
Posts: 2
Joined: Thu Jan 28, 2021 5:40 pm

Fri Jan 29, 2021 2:13 am

it worked!
The only thing is i needed to hit choose and browse to the folder vs just removing \uninstaller.exe

Thanks for the quick response!
manuel
Posts: 1
Joined: Fri Jan 29, 2021 7:22 pm

Fri Jan 29, 2021 7:26 pm

I ran into the same issue after the upgrade, but now Unimus is not loading. OpenJDK has been using 100% of the CPU for the past hour and the WebUI doesn't load. Any ideas?
User avatar
Tomas
Posts: 983
Joined: Sat Jun 25, 2016 12:33 pm

Tue Mar 09, 2021 6:14 pm

Just an update if anyone finds this topic in the future:
- the installer issues mentioned in the OP are fixed in newer 2.x installers and migrations from older versions will work properly
- the issue manuel mentioned was due to a corrupted HSQL DB, we have fixed it - if anyone else runs into this, just contact us
Post Reply