Upgrade to 0.3.x or newer from older versions

Unimus support forum
Post Reply
User avatar
Tomas
Posts: 649
Joined: Sat Jun 25, 2016 12:33 pm

Thu Feb 16, 2017 6:12 pm

Direct upgrade to 0.3.x or newer from 0.2.x nor 0.1.x is not supported.
Configuration file format has changed, as well as the database schema has changed.

We are sorry for the trouble this causes, but it was necessary to implement support for automatic database upgrades going forward.
We promise this is the last time that a database wipe is necessary - since automatic database upgrades are now fully functional with 0.3.0 and will be used by all future releases from now on.

If you are running 0.2.x or older, in order to run 0.3.x or newer versions, you will need to:
1) Stop the current instance of Unimus

2) Delete the database
If using HSQL, this will be in:
'C:\ProgramData\Unimus\hsql' on Windows
'/etc/unimus/hsql' on Linux/Unix/Mac

If using MySQL, you will need to drop the database (or drop all tables).

3) Delete the configuration file
'C:\ProgramData\Unimus\unimus.properties' on Windows
'/etc/unimus/unimus.properties' on Linux/Unix/Mac

4) Install Unimus as normal

Please let us know here if you run into any issues.
thobias
Posts: 19
Joined: Mon Aug 08, 2016 11:19 am

Fri Feb 17, 2017 8:16 am

Hi
I had 0.2.3 installed in tomcat on a ubuntu server. Dropped all tables in the DB and deleted the config file after stopping the current instance.
Then deploying the new .war in tomcat and starting the setup I had to create and set permissions for the tomcat user on the /var/log/unimus folder.
But now I am stuck at the database config page giving me this error Image
User avatar
Tomas
Posts: 649
Joined: Sat Jun 25, 2016 12:33 pm

Sat Feb 18, 2017 1:02 am

thobias wrote: But now I am stuck at the database config page giving me this error.
We are investigating this issues - issue only affects the .war distribution.
Will post and update as soon as a fix is available.
User avatar
Tomas
Posts: 649
Joined: Sat Jun 25, 2016 12:33 pm

Sat Feb 18, 2017 4:03 pm

thobias wrote: But now I am stuck at the database config page giving me this error.
We have found the issue and fixed it.
Will be fixed in 0.3.1 - which will be a hotfix release Monday/Tuesday next week.

Sorry for the inconvenience.
thobias
Posts: 19
Joined: Mon Aug 08, 2016 11:19 am

Tue Feb 21, 2017 11:47 am

Tomas wrote:
thobias wrote: But now I am stuck at the database config page giving me this error.
We have found the issue and fixed it.
Will be fixed in 0.3.1 - which will be a hotfix release Monday/Tuesday next week.

Sorry for the inconvenience.
Thanks, up and running now without any issues. :D
Post Reply